[aerogear-dev] jboss server missing/unsatisified dependencies

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] jboss server missing/unsatisified dependencies

Rachael O'Regan
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

Matthias Wessendorf
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

Matthias Wessendorf

On Mon, Aug 21, 2017 at 1:00 PM, Matthias Wessendorf <[hidden email]> wrote:
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

Matthias Wessendorf
In reply to this post by Matthias Wessendorf

On Mon, Aug 21, 2017 at 1:00 PM, Matthias Wessendorf <[hidden email]> wrote:
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

Rachael O'Regan
In reply to this post by Matthias Wessendorf
Hi Karel & Matthias,

Thanks for your suggested solutions but unfortunately I’m still seeing the same error.  I tried removing the xml code that referenced logmanager and I also tried changing the name to how it is defined in jboss/modules/system/layers/base/org/jboss/logmanager/main/module.xml which is name=“org.jboss.logmanager”. I also tried removing the xml code for logmanager and removing the data directory inside jboss/standalone. 

Any other suggestions?

Thanks,

RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan

On 21 Aug 2017, at 12:01, Matthias Wessendorf <[hidden email]> wrote:


On Mon, Aug 21, 2017 at 1:00 PM, Matthias Wessendorf <[hidden email]> wrote:
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



-- 



-- 
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

tolis emmanouilidis
Hello,

Maybe you could try the opposite direction, to install the missing module. Your standalone xml is using jboss-logmanager-ext [1] module which adds extra functionality to the standard org.jboss.logmanager module pre-included by JBoss EAP.

The log file mentions that the module cannot be loaded. You may install it using CLI (if your server can be started e.g on admin-only mode and then execute the CLI) or manually (if your server cannot be started).

CLI:

batch

module add --name=org.jboss.logmanager.ext --dependencies=org.jboss.logmanager,javax.json.api,javax.xml.stream.api --resources=~/your_folder_where_the_downloaded_module_exists/jboss-logmanager-ext-1.0.0.Alpha3.jar :reload run-batch
Manual procedure

Create the org/jboss/logmanager/ext/main folder. Add the downloaded JBoss Log Manager Ext jar inside it. Create a module.xml containing something like the following:

<?xml version="1.0" encoding="UTF-8"?>
<module xmlns="urn:jboss:module:1.0" name="org.jboss.logmanager.ext">
<resources>
    <resource-root path="jboss-logmanager-ext-1.0.0.Alpha3.jar"/>
</resources>
<dependencies>
    <module name="org.jboss.logmanager"/>
    <module name="javax.json.api"/>
    <module name="javax.xml.stream.api"/>
  </dependencies>
</module>


resource-root path should refer to the version you downloaded
Not sure how your filesystem looks like, if you're using a custom location for your modules or if you're using a layered distribution

[1]:
https://github.com/jamezp/jboss-logmanager-ext

2017-08-21 17:37 GMT+03:00 Rachael O'Regan <[hidden email]>:
Hi Karel & Matthias,

Thanks for your suggested solutions but unfortunately I’m still seeing the same error.  I tried removing the xml code that referenced logmanager and I also tried changing the name to how it is defined in jboss/modules/system/layers/base/org/jboss/logmanager/main/module.xml which is name=“org.jboss.logmanager”. I also tried removing the xml code for logmanager and removing the data directory inside jboss/standalone. 

Any other suggestions?

Thanks,

RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan

On 21 Aug 2017, at 12:01, Matthias Wessendorf <[hidden email]> wrote:


On Mon, Aug 21, 2017 at 1:00 PM, Matthias Wessendorf <[hidden email]> wrote:
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



-- 



-- 
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] jboss server missing/unsatisified dependencies

Matthias Wessendorf
that logger is not needed at all.

this is a problem on the running EAP. It's not correctly configured

On Mon, Aug 21, 2017 at 8:15 PM, Tolis Emmanouilidis <[hidden email]> wrote:
Hello,

Maybe you could try the opposite direction, to install the missing module. Your standalone xml is using jboss-logmanager-ext [1] module which adds extra functionality to the standard org.jboss.logmanager module pre-included by JBoss EAP.

The log file mentions that the module cannot be loaded. You may install it using CLI (if your server can be started e.g on admin-only mode and then execute the CLI) or manually (if your server cannot be started).

CLI:

batch

module add --name=org.jboss.logmanager.ext --dependencies=org.jboss.logmanager,javax.json.api,javax.xml.stream.api --resources=~/your_folder_where_the_downloaded_module_exists/jboss-logmanager-ext-1.0.0.Alpha3.jar :reload run-batch
Manual procedure

Create the org/jboss/logmanager/ext/main folder. Add the downloaded JBoss Log Manager Ext jar inside it. Create a module.xml containing something like the following:

<?xml version="1.0" encoding="UTF-8"?>
<module xmlns="urn:jboss:module:1.0" name="org.jboss.logmanager.ext">
<resources>
    <resource-root path="jboss-logmanager-ext-1.0.0.Alpha3.jar"/>
</resources>
<dependencies>
    <module name="org.jboss.logmanager"/>
    <module name="javax.json.api"/>
    <module name="javax.xml.stream.api"/>
  </dependencies>
</module>


resource-root path should refer to the version you downloaded
Not sure how your filesystem looks like, if you're using a custom location for your modules or if you're using a layered distribution

[1]:
https://github.com/jamezp/jboss-logmanager-ext

2017-08-21 17:37 GMT+03:00 Rachael O'Regan <[hidden email]>:
Hi Karel & Matthias,

Thanks for your suggested solutions but unfortunately I’m still seeing the same error.  I tried removing the xml code that referenced logmanager and I also tried changing the name to how it is defined in jboss/modules/system/layers/base/org/jboss/logmanager/main/module.xml which is name=“org.jboss.logmanager”. I also tried removing the xml code for logmanager and removing the data directory inside jboss/standalone. 

Any other suggestions?

Thanks,

RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan

On 21 Aug 2017, at 12:01, Matthias Wessendorf <[hidden email]> wrote:


On Mon, Aug 21, 2017 at 1:00 PM, Matthias Wessendorf <[hidden email]> wrote:
https://gist.github.com/rachael-oregan/ab5f268529e48c0f9fb253f82841db22#file-server-log-L104-L107

can you search inside the EAP instance if there is some mention / ref. on that "logmanager" ?

On Fri, Aug 18, 2017 at 1:56 PM, Rachael O'Regan <[hidden email]> wrote:
Hi all,

I’m having issues with the jboss server on my vm. It’s failing to start and the server log reports this error:

JBAS014775: New missing/unsatisfied dependencies: service jboss.remoting.endpoint.management (missing) dependents: [service jboss.remoting.management.channel.registry]

I’m using the latest fhcap and jboss-eap-6.4.15.


I’ve tried changing the config so remoting doesn’t use the management endpoint too - <remoting-connector use-management-endpoint=“false” /> 

I’ve created a new vm and still getting the same error.  Any help is appreciated.

Thanks,
RACHAEL O'REGAN
Red Hat Mobile
Communications House, Cork Road
Waterford City, Ireland X91NY33
[hidden email]    IM: roregan


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



-- 



-- 
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev