[aerogear-dev] building aerogear-android-todo

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] building aerogear-android-todo

danielbevenius
Hi!

just wanted to ask if anyone has had any issues building aerogear-android-todo? I think I must have missed something obvious here as it does not build for me :(
The details can be found here [1]

Thanks,

/Daniel


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] building aerogear-android-todo

Marko Strukelj
That's strange. Never had problems that you describe. Are you sure you're building the latest master?

You first need to build aerogear-android, only then aerogear-android-todo.

- marko


----- Original Message -----

>
> Hi!
>
>
> just wanted to ask if anyone has had any issues building
> aerogear-android-todo? I think I must have missed something obvious
> here as it does not build for me :(
> The details can be found here [1]
>
>
> Thanks,
>
>
> /Daniel
>
>
> [1] https://gist.github.com/3826704
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] building aerogear-android-todo

danielbevenius
Yeah, I'm sure I'm on the latest and I've followed the instructions in the README.md. 

Would you be able to purge your local maven repo by running the following command?
aerogear-android-todo$ mvn dependency:purge-local-repository -DreResolve=false

And then you'll have to run these to populate your local repo before building aerogear-android-todo again:
maven-android-sdk-deployer danbev$  mvn install -P 4.1

aerogear-android danbev$ mvn install

aerogear-android-todo danbev$ mvn install

If this works then something must be wrong with my local environment. 

Thanks for looking into this!

/Daniel

On 3 October 2012 15:19, Marko Strukelj <[hidden email]> wrote:
That's strange. Never had problems that you describe. Are you sure you're building the latest master?

You first need to build aerogear-android, only then aerogear-android-todo.

- marko


----- Original Message -----
>
> Hi!
>
>
> just wanted to ask if anyone has had any issues building
> aerogear-android-todo? I think I must have missed something obvious
> here as it does not build for me :(
> The details can be found here [1]
>
>
> Thanks,
>
>
> /Daniel
>
>
> [1] https://gist.github.com/3826704
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] building aerogear-android-todo

Luke Holmquist
In reply to this post by danielbevenius

i actually get the same error you are describing,  

On Oct 3, 2012, at 8:42 AM, Daniel Bevenius <[hidden email]> wrote:

Hi!

just wanted to ask if anyone has had any issues building aerogear-android-todo? I think I must have missed something obvious here as it does not build for me :(
The details can be found here [1]

Thanks,

/Daniel

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] building aerogear-android-todo

Glen Daniels
This has to do with some bad interaction with the settings.xml that is
recommended for building the TODO app.  Haven't had time to debug in
detail, but moving/renaming ~/.m2/settings.xml will resolve this.

I'm guessing that this means that there's a problem with the contents of
the settings.xml, but again I haven't yet been able to dig into it.

Thanks,
--Glen

On 10/3/12 9:42 AM, Lucas Holmquist wrote:

>
> i actually get the same error you are describing,  
>
> On Oct 3, 2012, at 8:42 AM, Daniel Bevenius <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>> Hi!
>>
>> just wanted to ask if anyone has had any issues building
>> aerogear-android-todo? I think I must have missed something obvious
>> here as it does not build for me :(
>> The details can be found here [1]
>>
>> Thanks,
>>
>> /Daniel
>>
>> [1] https://gist.github.com/3826704
>> _______________________________________________
>> aerogear-dev mailing list
>> [hidden email] <mailto:[hidden email]>
>> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>
>
>
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev