[aerogear-dev] UnifiedPush node sender

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] UnifiedPush node sender

Luke Holmquist
Currently the node sender for the UPS, is at 0.10.1,

which works with the  UPS version 1.1.x series.

Ive been thinking that perhaps we should update the node sender version to be in lock-step with the version of the UPS it works with.  

The only real problem with this is that the UPS 1.0.x uses the 0.7.x node sender.  but if we want to stay semver compliant,  we can't really make a 1.0.x node sender series since it would "reverting" things in the 0.8+ versions.


I'm thinking that perhaps we just bump the node sender to 1.1.1? or whatever the current release is of the UPS.  

hopefully if we keep things like this,  then it becomes less confusing for users to know what version of the sender to use with which version of the UPS

There is one issue i would like to get in though, before bumping the version.  https://issues.jboss.org/browse/AGJS-302  - this adds in using the request library.


thoughts?

-Luke

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] UnifiedPush node sender

Luke Holmquist
Something i was just thinking about though, is i would like to change the API to be promised based instead of using callbacks.  This would be a major API change, thus a Major version bump. 

So maybe making these things the same version might not be the best idea?  Or perhaps getting the API change done before the sync up in versions could also work?


i hate when i talk myself out of things :)

On Fri, Jan 29, 2016 at 10:38 AM, Luke Holmquist <[hidden email]> wrote:
Currently the node sender for the UPS, is at 0.10.1,

which works with the  UPS version 1.1.x series.

Ive been thinking that perhaps we should update the node sender version to be in lock-step with the version of the UPS it works with.  

The only real problem with this is that the UPS 1.0.x uses the 0.7.x node sender.  but if we want to stay semver compliant,  we can't really make a 1.0.x node sender series since it would "reverting" things in the 0.8+ versions.


I'm thinking that perhaps we just bump the node sender to 1.1.1? or whatever the current release is of the UPS.  

hopefully if we keep things like this,  then it becomes less confusing for users to know what version of the sender to use with which version of the UPS

There is one issue i would like to get in though, before bumping the version.  https://issues.jboss.org/browse/AGJS-302  - this adds in using the request library.


thoughts?

-Luke


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev