[aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

Lukáš Fryč
Hi guys,

we are working on delivering some improvements in UPS messaging subsystem in 1.2.0,

and part of that is also adoption of WF10 (with ActiveMQ Artemis underneath).


The problem is that WF10 is JDK8 only, so if we use it for tests, we are limiting ourselves to JDK8-only build. We could run it on WF8 with JDK7, off course.

Question is, do we want to support WF8 with UPS 1.2.0+, or should we switch to WF10 only?


Cheers,

~ Lukas

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

Matthias Wessendorf
For our work, required for supporting APNs' HTTP/2 APIs we also need JDK-8.

I wonder if we should call the release 2.0.0, and really aim only WF10/EAP7 + (Open)JDK-8

On Fri, Mar 18, 2016 at 9:31 AM, Lukáš Fryč <[hidden email]> wrote:
Hi guys,

we are working on delivering some improvements in UPS messaging subsystem in 1.2.0,

and part of that is also adoption of WF10 (with ActiveMQ Artemis underneath).


The problem is that WF10 is JDK8 only, so if we use it for tests, we are limiting ourselves to JDK8-only build. We could run it on WF8 with JDK7, off course.

Question is, do we want to support WF8 with UPS 1.2.0+, or should we switch to WF10 only?


Cheers,

~ Lukas

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

Matthias Wessendorf
Another thing is, Keycloak also is now JDK-8:

(current release is 1.9.1 and 2.0.0-CR1 is in the making)

And one of the JDKs even called Java7 dead, sure... that's not that important.

I am very supportive of this, especially our main server platforms (WildFly and EAP) are also Java8 only with the latest releases



On Fri, Mar 18, 2016 at 9:34 AM, Matthias Wessendorf <[hidden email]> wrote:
For our work, required for supporting APNs' HTTP/2 APIs we also need JDK-8.

I wonder if we should call the release 2.0.0, and really aim only WF10/EAP7 + (Open)JDK-8

On Fri, Mar 18, 2016 at 9:31 AM, Lukáš Fryč <[hidden email]> wrote:
Hi guys,

we are working on delivering some improvements in UPS messaging subsystem in 1.2.0,

and part of that is also adoption of WF10 (with ActiveMQ Artemis underneath).


The problem is that WF10 is JDK8 only, so if we use it for tests, we are limiting ourselves to JDK8-only build. We could run it on WF8 with JDK7, off course.

Question is, do we want to support WF8 with UPS 1.2.0+, or should we switch to WF10 only?


Cheers,

~ Lukas

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

Idel Pivnitskiy
+1 that release which works only with JDK-8 and WF10 should be called 2.0.0

+2 that time to move to JDK-8 :) of course if we don't have special requirements to support JDK-7

Best regards,
Idel Pivnitskiy
--

On Fri, Mar 18, 2016 at 11:41 AM, Matthias Wessendorf <[hidden email]> wrote:
Another thing is, Keycloak also is now JDK-8:

(current release is 1.9.1 and 2.0.0-CR1 is in the making)

And one of the JDKs even called Java7 dead, sure... that's not that important.

I am very supportive of this, especially our main server platforms (WildFly and EAP) are also Java8 only with the latest releases



On Fri, Mar 18, 2016 at 9:34 AM, Matthias Wessendorf <[hidden email]> wrote:
For our work, required for supporting APNs' HTTP/2 APIs we also need JDK-8.

I wonder if we should call the release 2.0.0, and really aim only WF10/EAP7 + (Open)JDK-8

On Fri, Mar 18, 2016 at 9:31 AM, Lukáš Fryč <[hidden email]> wrote:
Hi guys,

we are working on delivering some improvements in UPS messaging subsystem in 1.2.0,

and part of that is also adoption of WF10 (with ActiveMQ Artemis underneath).


The problem is that WF10 is JDK8 only, so if we use it for tests, we are limiting ourselves to JDK8-only build. We could run it on WF8 with JDK7, off course.

Question is, do we want to support WF8 with UPS 1.2.0+, or should we switch to WF10 only?


Cheers,

~ Lukas

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] UPS 1.2.0+ on WF10/JDK8 - should we continue supporting WF8/JDK7?

Matthias Wessendorf


On Fri, Mar 18, 2016 at 10:07 AM, Idel Pivnitskiy <[hidden email]> wrote:
+1 that release which works only with JDK-8 and WF10 should be called 2.0.0

+2 that time to move to JDK-8 :) of course if we don't have special requirements to support JDK-7

for HTTP/2 and APNs, we need JDK8, I think this is the important message here :)
 

Best regards,
Idel Pivnitskiy
--

On Fri, Mar 18, 2016 at 11:41 AM, Matthias Wessendorf <[hidden email]> wrote:
Another thing is, Keycloak also is now JDK-8:

(current release is 1.9.1 and 2.0.0-CR1 is in the making)

And one of the JDKs even called Java7 dead, sure... that's not that important.

I am very supportive of this, especially our main server platforms (WildFly and EAP) are also Java8 only with the latest releases



On Fri, Mar 18, 2016 at 9:34 AM, Matthias Wessendorf <[hidden email]> wrote:
For our work, required for supporting APNs' HTTP/2 APIs we also need JDK-8.

I wonder if we should call the release 2.0.0, and really aim only WF10/EAP7 + (Open)JDK-8

On Fri, Mar 18, 2016 at 9:31 AM, Lukáš Fryč <[hidden email]> wrote:
Hi guys,

we are working on delivering some improvements in UPS messaging subsystem in 1.2.0,

and part of that is also adoption of WF10 (with ActiveMQ Artemis underneath).


The problem is that WF10 is JDK8 only, so if we use it for tests, we are limiting ourselves to JDK8-only build. We could run it on WF8 with JDK7, off course.

Question is, do we want to support WF8 with UPS 1.2.0+, or should we switch to WF10 only?


Cheers,

~ Lukas

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev