[aerogear-dev] TODO App - Installation README

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] TODO App - Installation README

cvasilak
Hi,

setting up my dev environment and trying to install the TODO app from the aerogear repo [1], I came across to a little problem. Although the instructions say to do "maven clean install" to produce the ear, *and then* start JBoss, what I experience is a build-failure  on TODO-EAR if the AS is not already started prior to the build.

I think we need to update the doc to explicitly say start JBoss AS prior to do "maven clean install" or disable "auto-deploy" on build. Need to check the jboss-as maven plugin..

Regards
Christos

[1] https://github.com/aerogear/TODO
_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] TODO App - Installation README

Matthias Wessendorf
Hi,

I run 'mvn clean package' and copy the EAR file to the server
(no need to have JBoss AS7 running, while building)


-M

On Fri, Sep 21, 2012 at 9:57 AM, Christos Vasilakis <[hidden email]> wrote:

> Hi,
>
> setting up my dev environment and trying to install the TODO app from the aerogear repo [1], I came across to a little problem. Although the instructions say to do "maven clean install" to produce the ear, *and then* start JBoss, what I experience is a build-failure  on TODO-EAR if the AS is not already started prior to the build.
>
> I think we need to update the doc to explicitly say start JBoss AS prior to do "maven clean install" or disable "auto-deploy" on build. Need to check the jboss-as maven plugin..
>
> Regards
> Christos
>
> [1] https://github.com/aerogear/TODO
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev



--
Matthias Wessendorf

blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
twitter: http://twitter.com/mwessendorf

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] TODO App - Installation README

cvasilak
... and also noticed that the correct link is [1]  instead of [2]  as we state in the document.

we set it so in ear's  application.xml
...
      <web-uri>todo-www.war</web-uri>
      <context-root>/todo</context-root>
..


[1] http://localhost:8080/todo/
[2] http://localhost:8080/todo-www/ 


On 21 Σεπ 2012, at 11:01 π.μ., Matthias Wessendorf wrote:


> On Fri, Sep 21, 2012 at 9:57 AM, Christos Vasilakis <[hidden email]> wrote:
>> Hi,
>>
>> setting up my dev environment and trying to install the TODO app from the aerogear repo [1], I came across to a little problem. Although the instructions say to do "maven clean install" to produce the ear, *and then* start JBoss, what I experience is a build-failure  on TODO-EAR if the AS is not already started prior to the build.
>>
>> I think we need to update the doc to explicitly say start JBoss AS prior to do "maven clean install" or disable "auto-deploy" on build. Need to check the jboss-as maven plugin..
>>
>> Regards
>> Christos
>>
>> [1] https://github.com/aerogear/TODO
>> _______________________________________________
>> aerogear-dev mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>
>
>
> --
> Matthias Wessendorf
>
> blog: http://matthiaswessendorf.wordpress.com/
> sessions: http://www.slideshare.net/mwessendorf
> twitter: http://twitter.com/mwessendorf
>
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] TODO App - Installation README

Matthias Wessendorf
fixed

https://github.com/aerogear/TODO/commit/81ee6f19799da9893c126aa46e35d7acd48c49fb

.M

On Fri, Sep 21, 2012 at 10:50 AM, Christos Vasilakis <[hidden email]> wrote:

> ... and also noticed that the correct link is [1]  instead of [2]  as we state in the document.
>
> we set it so in ear's  application.xml
> ...
>       <web-uri>todo-www.war</web-uri>
>       <context-root>/todo</context-root>
> ..
>
>
> [1] http://localhost:8080/todo/
> [2] http://localhost:8080/todo-www/
>
>
> On 21 Σεπ 2012, at 11:01 π.μ., Matthias Wessendorf wrote:
>
>
>> On Fri, Sep 21, 2012 at 9:57 AM, Christos Vasilakis <[hidden email]> wrote:
>>> Hi,
>>>
>>> setting up my dev environment and trying to install the TODO app from the aerogear repo [1], I came across to a little problem. Although the instructions say to do "maven clean install" to produce the ear, *and then* start JBoss, what I experience is a build-failure  on TODO-EAR if the AS is not already started prior to the build.
>>>
>>> I think we need to update the doc to explicitly say start JBoss AS prior to do "maven clean install" or disable "auto-deploy" on build. Need to check the jboss-as maven plugin..
>>>
>>> Regards
>>> Christos
>>>
>>> [1] https://github.com/aerogear/TODO
>>> _______________________________________________
>>> aerogear-dev mailing list
>>> [hidden email]
>>> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>>
>>
>>
>> --
>> Matthias Wessendorf
>>
>> blog: http://matthiaswessendorf.wordpress.com/
>> sessions: http://www.slideshare.net/mwessendorf
>> twitter: http://twitter.com/mwessendorf
>>
>> _______________________________________________
>> aerogear-dev mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-dev
>
>
> _______________________________________________
> aerogear-dev mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-dev



--
Matthias Wessendorf

blog: http://matthiaswessendorf.wordpress.com/
sessions: http://www.slideshare.net/mwessendorf
twitter: http://twitter.com/mwessendorf

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] TODO App - Installation README

Bruno Oliveira
Awesome, thanks Matthias!


-- 
"The measure of a man is what he does with power" - Plato
-
@abstractj
-
Volenti Nihil Difficile

On Friday, September 21, 2012 at 5:55 AM, Matthias Wessendorf wrote:

fixed


.M

On Fri, Sep 21, 2012 at 10:50 AM, Christos Vasilakis <[hidden email]> wrote:
... and also noticed that the correct link is [1] instead of [2] as we state in the document.

we set it so in ear's application.xml
...
<web-uri>todo-www.war</web-uri>
<context-root>/todo</context-root>
..




On 21 Σεπ 2012, at 11:01 π.μ., Matthias Wessendorf wrote:


On Fri, Sep 21, 2012 at 9:57 AM, Christos Vasilakis <[hidden email]> wrote:
Hi,

setting up my dev environment and trying to install the TODO app from the aerogear repo [1], I came across to a little problem. Although the instructions say to do "maven clean install" to produce the ear, *and then* start JBoss, what I experience is a build-failure on TODO-EAR if the AS is not already started prior to the build.

I think we need to update the doc to explicitly say start JBoss AS prior to do "maven clean install" or disable "auto-deploy" on build. Need to check the jboss-as maven plugin..

Regards
Christos

_______________________________________________
aerogear-dev mailing list



--
Matthias Wessendorf


_______________________________________________
aerogear-dev mailing list


_______________________________________________
aerogear-dev mailing list



--
Matthias Wessendorf


_______________________________________________
aerogear-dev mailing list


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev