[aerogear-dev] Swift 2.3 updates to AeroGearOAuth2 & AeroGearHttp

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] Swift 2.3 updates to AeroGearOAuth2 & AeroGearHttp

Michael Doo
Hello,

There are two new pull requests to the AeroGearOAuth2 and AeroGearHttp libraries to bring them up to date with the latest Xcode 8 beta (beta 3) and Swift 2.3. They are PR #53 on OAuth2 and #70 on Http. Note that for the Http project, PR #70 overrides previously submitted PR #67.

Once these are merged in, I plan to open new branches for iOS 10 targets and Swift 3. Both will potentially be pretty hairy, as iOS 10 changed a number of behaviors related to NSURL and Swift 3 contains a whole host of changes to the language. I don't think there will be any harm in having minimum targets for either project be at least iOS 9, but they should also be compatible with iOS 10.

Best,
Michael Doo
410 Labs

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Swift 2.3 updates to AeroGearOAuth2 & AeroGearHttp

Daniel Passos-3
Hi Michael,

First of all sorry for my late reply and thanks so much for your contributions I really appreciate that.

I'll take a look at it asap.

On Thu, Jul 21, 2016 at 5:27 PM, Michael Doo <[hidden email]> wrote:
Hello,

There are two new pull requests to the AeroGearOAuth2 and AeroGearHttp libraries to bring them up to date with the latest Xcode 8 beta (beta 3) and Swift 2.3. They are PR #53 on OAuth2 and #70 on Http. Note that for the Http project, PR #70 overrides previously submitted PR #67.

Once these are merged in, I plan to open new branches for iOS 10 targets and Swift 3. Both will potentially be pretty hairy, as iOS 10 changed a number of behaviors related to NSURL and Swift 3 contains a whole host of changes to the language. I don't think there will be any harm in having minimum targets for either project be at least iOS 9, but they should also be compatible with iOS 10.

Best,
Michael Doo
410 Labs

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--
-- Passos

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev