Quantcast

[aerogear-dev] Stream of Exceptions in log when using fake data

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[aerogear-dev] Stream of Exceptions in log when using fake data

Jose Miguel Gallas Olmedo
Hi all,

I am playing a bit with the admin-ui and added some fake variant. When trying to send a notification, a 500 Error popup showed up and the terminal spat out a couple of ugly Exceptions -> https://gist.github.com/josemigallas/614a7ffe01e213b25470bfa11925a365

What I did is create a new Android variant with some madeup senderId and serverKey and then add some fake tokens with the mock-data-loader.

I don't really know if this is some kind of error but I wouldn't expect so many Exceptions. It should simply check the response from FCM, not throwing exceptions here and there. Maybe it has nothing to do with it and I am just doing something else wrong.

WDYT?

Cheers,

--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Stream of Exceptions in log when using fake data

Matthias Wessendorf
Let me guess: you reuse a DB from the 1.1.x testing, but run with master ? I see undertow, which is WildFly, and only supported on master

the DB schema for 1.1.x branch (the one we test w/ EAP) is different than the one in master (the one we test w/ WildFly)

NOTE: the master code does NOT yet contain the APNs/HTTP2 fixes. I had no time to port that forward 

On Tue, May 9, 2017 at 4:58 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Hi all,

I am playing a bit with the admin-ui and added some fake variant. When trying to send a notification, a 500 Error popup showed up and the terminal spat out a couple of ugly Exceptions -> https://gist.github.com/josemigallas/614a7ffe01e213b25470bfa11925a365

What I did is create a new Android variant with some madeup senderId and serverKey and then add some fake tokens with the mock-data-loader.

I don't really know if this is some kind of error but I wouldn't expect so many Exceptions. It should simply check the response from FCM, not throwing exceptions here and there. Maybe it has nothing to do with it and I am just doing something else wrong.

WDYT?

Cheers,

--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Stream of Exceptions in log when using fake data

Jose Miguel Gallas Olmedo
Hi Matthias,

No, I'm using 1.1.x-dev all the time, I just checked it again. I didn't do anything with the DB though, is it necessary to update it as well?

Cheers,

On 9 May 2017 at 19:39, Matthias Wessendorf <[hidden email]> wrote:
Let me guess: you reuse a DB from the 1.1.x testing, but run with master ? I see undertow, which is WildFly, and only supported on master

the DB schema for 1.1.x branch (the one we test w/ EAP) is different than the one in master (the one we test w/ WildFly)

NOTE: the master code does NOT yet contain the APNs/HTTP2 fixes. I had no time to port that forward 

On Tue, May 9, 2017 at 4:58 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Hi all,

I am playing a bit with the admin-ui and added some fake variant. When trying to send a notification, a 500 Error popup showed up and the terminal spat out a couple of ugly Exceptions -> https://gist.github.com/josemigallas/614a7ffe01e213b25470bfa11925a365

What I did is create a new Android variant with some madeup senderId and serverKey and then add some fake tokens with the mock-data-loader.

I don't really know if this is some kind of error but I wouldn't expect so many Exceptions. It should simply check the response from FCM, not throwing exceptions here and there. Maybe it has nothing to do with it and I am just doing something else wrong.

WDYT?

Cheers,

--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Stream of Exceptions in log when using fake data

Matthias Wessendorf
Ah, good :-)

undertow in stack trace tells me you use WildFly.

Please use EAP 6.4.x (.11 for instance) with 1.1.x


On Wed, 10 May 2017 at 09:46, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Hi Matthias,

No, I'm using 1.1.x-dev all the time, I just checked it again. I didn't do anything with the DB though, is it necessary to update it as well?

Cheers,

On 9 May 2017 at 19:39, Matthias Wessendorf <[hidden email]> wrote:
Let me guess: you reuse a DB from the 1.1.x testing, but run with master ? I see undertow, which is WildFly, and only supported on master

the DB schema for 1.1.x branch (the one we test w/ EAP) is different than the one in master (the one we test w/ WildFly)

NOTE: the master code does NOT yet contain the APNs/HTTP2 fixes. I had no time to port that forward 

On Tue, May 9, 2017 at 4:58 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Hi all,

I am playing a bit with the admin-ui and added some fake variant. When trying to send a notification, a 500 Error popup showed up and the terminal spat out a couple of ugly Exceptions -> https://gist.github.com/josemigallas/614a7ffe01e213b25470bfa11925a365

What I did is create a new Android variant with some madeup senderId and serverKey and then add some fake tokens with the mock-data-loader.

I don't really know if this is some kind of error but I wouldn't expect so many Exceptions. It should simply check the response from FCM, not throwing exceptions here and there. Maybe it has nothing to do with it and I am just doing something else wrong.

WDYT?

Cheers,

--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

JOSE MIGUEL GALLAS OLMEDO

ASSOCIATE QE, mobile

Red Hat 

<span href="tel:+34618488633">M: +34618488633    

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
--
Sent from Gmail Mobile

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Loading...