[aerogear-dev] Problem on migrating to 1.1.0-Final

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev

error_log_MigrationTool.txt (16K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Matthias Wessendorf
Hi Romain,

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.




On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Matthias Wessendorf
Hwllo,

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Matthias Wessendorf
yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev-bounces@lists.jboss.org&#39;);" target="_blank">aerogear-dev-bounces@... [mailto:<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev-bounces@lists.jboss.org&#39;);" target="_blank">aerogear-dev-bounces@...] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;Romain.Javornik@saint-gobain.com&#39;);" target="_blank">Romain.Javornik@...> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : <a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev-bounces@lists.jboss.org&#39;);" target="_blank">aerogear-dev-bounces@... [mailto:<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev-bounces@lists.jboss.org&#39;);" target="_blank">aerogear-dev-bounces@...] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;Romain.Javornik@saint-gobain.com&#39;);" target="_blank">Romain.Javornik@...> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev@lists.jboss.org&#39;);" target="_blank">aerogear-dev@...
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
<a href="javascript:_e(%7B%7D,&#39;cvml&#39;,&#39;aerogear-dev@lists.jboss.org&#39;);" target="_blank">aerogear-dev@...
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Hello,

 

Since your advice we have made an upgrade to a supported version : JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

 

I don’t have try to upgrade Aerogear to the 1.1.0 yet because I’m facing issue on the new JBoss with my current 1.0.2

I’ve joined my JBoss logs to the mail, it appear that the problem might come from the jar keycloak  1.0.4.

 

After some research it is not compatible with the current JBoss version, can you confirm ?

 

Best Regards,

Romain Javornik

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 15:02
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : <a href="javascript:_e(%7B%7D,'cvml','aerogear-dev-bounces@lists.jboss.org');" target="_blank"> aerogear-dev-bounces@... [mailto:<a href="javascript:_e(%7B%7D,'cvml','aerogear-dev-bounces@lists.jboss.org');" target="_blank">aerogear-dev-bounces@...] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <<a href="javascript:_e(%7B%7D,'cvml','Romain.Javornik@saint-gobain.com');" target="_blank">Romain.Javornik@...> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : <a href="javascript:_e(%7B%7D,'cvml','aerogear-dev-bounces@lists.jboss.org');" target="_blank"> aerogear-dev-bounces@... [mailto:<a href="javascript:_e(%7B%7D,'cvml','aerogear-dev-bounces@lists.jboss.org');" target="_blank">aerogear-dev-bounces@...] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <<a href="javascript:_e(%7B%7D,'cvml','Romain.Javornik@saint-gobain.com');" target="_blank">Romain.Javornik@...> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
<a href="javascript:_e(%7B%7D,'cvml','aerogear-dev@lists.jboss.org');" target="_blank">aerogear-dev@...
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
<a href="javascript:_e(%7B%7D,'cvml','aerogear-dev@lists.jboss.org');" target="_blank">aerogear-dev@...
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev

jboss.log (21K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Matthias Wessendorf
Hi,

hrm, I just did download a fresh copy of UPS 1.0.2 and did a successful deploy into the following EAP 6.4.x versions:
* JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)
* JBoss EAP 6.4.4.GA (AS 7.5.4.Final-redhat-4)

I did that, both, w/ Java8:

        java.runtime.name = Java(TM) SE Runtime Environment
        java.runtime.version = 1.8.0_65-b17
        java.specification.name = Java Platform API Specification
        java.specification.vendor = Oracle Corporation
        java.specification.version = 1.8


Note: I did fresh deployment

On Thu, Jan 7, 2016 at 11:43 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

Since your advice we have made an upgrade to a supported version : JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

 

I don’t have try to upgrade Aerogear to the 1.1.0 yet because I’m facing issue on the new JBoss with my current 1.0.2

I’ve joined my JBoss logs to the mail, it appear that the problem might come from the jar keycloak  1.0.4.

 

After some research it is not compatible with the current JBoss version, can you confirm ?

 

Best Regards,

Romain Javornik

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 15:02


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Can you detail your installation procedure ? May be I miss something …

 

Thanks for your time

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 7 janvier 2016 14:29
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi,

 

hrm, I just did download a fresh copy of UPS 1.0.2 and did a successful deploy into the following EAP 6.4.x versions:

* JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

* JBoss EAP 6.4.4.GA (AS 7.5.4.Final-redhat-4)

 

I did that, both, w/ Java8:

 

        java.runtime.name = Java(TM) SE Runtime Environment

        java.runtime.version = 1.8.0_65-b17

        java.specification.name = Java Platform API Specification

        java.specification.vendor = Oracle Corporation

        java.specification.version = 1.8

 

 

Note: I did fresh deployment

 

On Thu, Jan 7, 2016 at 11:43 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

Since your advice we have made an upgrade to a supported version : JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

 

I don’t have try to upgrade Aerogear to the 1.1.0 yet because I’m facing issue on the new JBoss with my current 1.0.2

I’ve joined my JBoss logs to the mail, it appear that the problem might come from the jar keycloak  1.0.4.

 

After some research it is not compatible with the current JBoss version, can you confirm ?

 

Best Regards,

Romain Javornik

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 15:02


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Matthias Wessendorf
I did copy the WAR files (with cp) into the deployments folder, and did launch the (configured) server with:

 ./bin/standalone.sh -b 0.0.0.0 --server-config=standalone-full.xml

What is your java version? I do not think it's related, but just asking :)

On Thu, Jan 7, 2016 at 3:12 PM, Javornik, Romain <[hidden email]> wrote:

Can you detail your installation procedure ? May be I miss something …

 

Thanks for your time

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 7 janvier 2016 14:29


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi,

 

hrm, I just did download a fresh copy of UPS 1.0.2 and did a successful deploy into the following EAP 6.4.x versions:

* JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

* JBoss EAP 6.4.4.GA (AS 7.5.4.Final-redhat-4)

 

I did that, both, w/ Java8:

 

        java.runtime.name = Java(TM) SE Runtime Environment

        java.runtime.version = 1.8.0_65-b17

        java.specification.name = Java Platform API Specification

        java.specification.vendor = Oracle Corporation

        java.specification.version = 1.8

 

 

Note: I did fresh deployment

 

On Thu, Jan 7, 2016 at 11:43 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

Since your advice we have made an upgrade to a supported version : JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

 

I don’t have try to upgrade Aerogear to the 1.1.0 yet because I’m facing issue on the new JBoss with my current 1.0.2

I’ve joined my JBoss logs to the mail, it appear that the problem might come from the jar keycloak  1.0.4.

 

After some research it is not compatible with the current JBoss version, can you confirm ?

 

Best Regards,

Romain Javornik

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 15:02


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|

Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

Javornik, Romain

Hello,

 

My java version is : 1.7.0_75

 

I’ve down some test and it appear that there is a problem with the database. I saw the script to create the database for the 1.0.2, but I don’t see it for 1.0.3.

Does the only way to have a database in 1.0.3 is by upgrading the 1.0.2 ?

 

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 7 janvier 2016 21:15
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

I did copy the WAR files (with cp) into the deployments folder, and did launch the (configured) server with:

 

 ./bin/standalone.sh -b 0.0.0.0 --server-config=standalone-full.xml

 

What is your java version? I do not think it's related, but just asking :)

 

On Thu, Jan 7, 2016 at 3:12 PM, Javornik, Romain <[hidden email]> wrote:

Can you detail your installation procedure ? May be I miss something …

 

Thanks for your time

Romain

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 7 janvier 2016 14:29


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi,

 

hrm, I just did download a fresh copy of UPS 1.0.2 and did a successful deploy into the following EAP 6.4.x versions:

* JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

* JBoss EAP 6.4.4.GA (AS 7.5.4.Final-redhat-4)

 

I did that, both, w/ Java8:

 

        java.runtime.name = Java(TM) SE Runtime Environment

        java.runtime.version = 1.8.0_65-b17

        java.specification.name = Java Platform API Specification

        java.specification.vendor = Oracle Corporation

        java.specification.version = 1.8

 

 

Note: I did fresh deployment

 

On Thu, Jan 7, 2016 at 11:43 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

Since your advice we have made an upgrade to a supported version : JBoss EAP 6.4.0.GA (AS 7.5.0.Final-redhat-21)

 

I don’t have try to upgrade Aerogear to the 1.1.0 yet because I’m facing issue on the new JBoss with my current 1.0.2

I’ve joined my JBoss logs to the mail, it appear that the problem might come from the jar keycloak  1.0.4.

 

After some research it is not compatible with the current JBoss version, can you confirm ?

 

Best Regards,

Romain Javornik

 

De : [hidden email] [mailto:[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 15:02


À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

yeah, its using quite old hibernate too

On Tuesday, 24 November 2015, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I’m currently on JBoss EAP 6.0.1.GA (AS 7.1.3.Final-redhat-4), do you think it might be the reason of all my trouble ?

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : mardi 24 novembre 2015 14:41
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hwllo,

 

I see "as7" - what version of JBoss are you using? We don't really support the JBoss7.1 server anymore. We have support for WildFly 8 and 9. Bsides that we have EAP_6.4.0 as one of the supported servers

 

On Tue, Nov 24, 2015 at 2:08 PM, Javornik, Romain <[hidden email]> wrote:

Hello Matthias,

 

I try to do a step by step like you suggest.

 

The migration of the database between 1.0.2 and 1.03 worked perfectly, but I can’t deploy  unifiedpush-server-as7.war

 

2015-11-24 11:45:45,457 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment unifiedpush-server-as7.war in 20ms

2015-11-24 11:45:45,458 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.persistenceunit.\"unifiedpush-server as7.war#unifiedpush-default\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"unifiedpush-server-as7.war#unifiedpush-default\": javax.persistence.Persisten

ceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: javax.persistence.PersistenceException: [PersistenceUnit: unifiedpush-default] Unable to build EntityManagerFactory

    Caused by: org.hibernate.HibernateException: Wrong column type in unifiedpush_tmp.VariantMetricInformation for column deliveryStatus. Found: bit, expected: boolean"

 

I’m currently trying to make some change in the type of the column deliveryStatus to see if it make a difference.

 

Best Regards,

Romain

 

De : [hidden email] [[hidden email]] De la part de Matthias Wessendorf
Envoyé : jeudi 19 novembre 2015 15:25
À : AeroGear Developer Mailing List
Objet : Re: [aerogear-dev] Problem on migrating to 1.1.0-Final

 

Hi Romain,

 

unfortunately I don't think the 1.0.2 -> 1.1.0.Final really works. I think you have to go to 1.0.3 first, before being able to run the migration towards 1.1.0.Final.

 

 

 

 

On Thu, Nov 19, 2015 at 11:22 AM, Javornik, Romain <[hidden email]> wrote:

Hello,

 

I don’t really know if this is the right email address for asking question but I give it a try, please redirect me if I’m wrong !

 

 

 

 

------ Problem in the UnifiedPush Server User Guide ------

 

Before explaining my problem I want to tell you that something isn’t clear enough from my point of view in your migration guide (https://aerogear.org/docs/unifiedpush/ups_userguide/index/#migration-guide).

 

On the part where you explain the database migration for mysql you write :

            MySQL

Inside of the extracted zip file, there is a liquibase-mysql-example.properties, copy that to liquibase.properties.

cp liquibase-mysql-example.properties liquibase.properties

Once done, you need to edit the new file to match your database name and credentials.

 

The problem with this is that you can’t choose the version you want to upgrade to.

Since I have “changeLogFile=liquibase/master.xml” in my liquidbase.properties, the only upgrade I was able to make was to the 1.0.0-Final and I’m on the 1.0.2.

I had to open the ups-migrator.jar (wich wasn’t really userfriendly) to see what was my option. And then I was able to go the version I want (exemple -> “changeLogFile=liquibase/1.1.0-Final/releasechanges.xml”)

 

To conclude I think that just a small explanation in the migration guide will make everything more clear.

 

 

 

 

 

------ My migration problem ------

 

I’m currently using AerogearPush Server 1.0.2 and I want to go to the 1.1.0-Final version.

 

I download the last package (1.1.0-Final) on this page https://aerogear.org/getstarted/downloads

 

Like explain above I had some trouble make it work to move to the version I wanted.

Right now in 1.0.2 I can use the Migrator Tool to make sure that my 1.0.2 Mysql database is good and to upgrade it to 1.0.3.

 

But I can’t go the 1.1.0-Final, I join to this email the error I get from the Migrator Tool.

 

Can you please tell me where the problem might come from or if you have any solution ?

 

 

 

Best Regards,

Romain


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--



--
Sent from Gmail Mobile


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



 

--


_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev