[aerogear-dev] Mysterious warning when sending push

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[aerogear-dev] Mysterious warning when sending push

Jose Miguel Gallas Olmedo
Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
+34 618 488 633

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Jose Miguel Gallas Olmedo
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
+34 618 488 633

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Matthias Wessendorf-2
and the tool that intercepts the requests also sends back some meaning full reponse ? 

like described here:



On Wed, Jan 25, 2017 at 3:49 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Jose Miguel Gallas Olmedo
No, it just sends "null". But that does not seem to be an issue for the first app :/

On 25 January 2017 at 15:56, Matthias Wessendorf <[hidden email]> wrote:
and the tool that intercepts the requests also sends back some meaning full reponse ? 

like described here:



On Wed, Jan 25, 2017 at 3:49 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
+34 618 488 633

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Matthias Wessendorf-2
the mock backend needs to have a response, that google's FCM lib (which is used in UPS), needs to understand. Otherwise, well ... sure, no luck.

In case you are using wiremock, please do something like:
curl -X POST --data '{ "request": { "url": "/fcm/send", "method": "POST" }, "response": { "status": 200, "fixedDelayMilliseconds": 2000, "jsonBody": {"multicast_id": 108,"success": 1,"failure": 0,"canonical_ids": 0,"results": [{ "message_id": "1:08"}]}, "headers": {"Content-Type": "application/json"}}}' http://localhost:9090/__admin/mappings/new
so that the loclahost:3000/fcm/send thing sends a meaningful response.

-Matthias



On Wed, Jan 25, 2017 at 5:38 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
No, it just sends "null". But that does not seem to be an issue for the first app :/

On 25 January 2017 at 15:56, Matthias Wessendorf <[hidden email]> wrote:
and the tool that intercepts the requests also sends back some meaning full reponse ? 

like described here:



On Wed, Jan 25, 2017 at 3:49 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Jose Miguel Gallas Olmedo
All right, I didn't have the mock server up, which makes me feel yet more confused. I have realised it today 'cause I got a "Failed" after sending a notification, however yesterday I got only "Pending".. why? It looks like it shows "Pending" when sending to multiple variants but when it is only one, the status is "Failed".

On 25 January 2017 at 19:29, Matthias Wessendorf <[hidden email]> wrote:
the mock backend needs to have a response, that google's FCM lib (which is used in UPS), needs to understand. Otherwise, well ... sure, no luck.

In case you are using wiremock, please do something like:
curl -X POST --data '{ "request": { "url": "/fcm/send", "method": "POST" }, "response": { "status": 200, "fixedDelayMilliseconds": 2000, "jsonBody": {"multicast_id": 108,"success": 1,"failure": 0,"canonical_ids": 0,"results": [{ "message_id": "1:08"}]}, "headers": {"Content-Type": "application/json"}}}' http://localhost:9090/__admin/mappings/new
so that the loclahost:3000/fcm/send thing sends a meaningful response.

-Matthias



On Wed, Jan 25, 2017 at 5:38 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
No, it just sends "null". But that does not seem to be an issue for the first app :/

On 25 January 2017 at 15:56, Matthias Wessendorf <[hidden email]> wrote:
and the tool that intercepts the requests also sends back some meaning full reponse ? 

like described here:



On Wed, Jan 25, 2017 at 3:49 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
+34 618 488 633

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [aerogear-dev] Mysterious warning when sending push

Matthias Wessendorf
Pending -> might be a UI glitch - not 100% sure

On Thu, Jan 26, 2017 at 9:52 AM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
All right, I didn't have the mock server up, which makes me feel yet more confused. I have realised it today 'cause I got a "Failed" after sending a notification, however yesterday I got only "Pending".. why? It looks like it shows "Pending" when sending to multiple variants but when it is only one, the status is "Failed".

On 25 January 2017 at 19:29, Matthias Wessendorf <[hidden email]> wrote:
the mock backend needs to have a response, that google's FCM lib (which is used in UPS), needs to understand. Otherwise, well ... sure, no luck.

In case you are using wiremock, please do something like:
curl -X POST --data '{ "request": { "url": "/fcm/send", "method": "POST" }, "response": { "status": 200, "fixedDelayMilliseconds": 2000, "jsonBody": {"multicast_id": 108,"success": 1,"failure": 0,"canonical_ids": 0,"results": [{ "message_id": "1:08"}]}, "headers": {"Content-Type": "application/json"}}}' http://localhost:9090/__admin/mappings/new
so that the loclahost:3000/fcm/send thing sends a meaningful response.

-Matthias



On Wed, Jan 25, 2017 at 5:38 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
No, it just sends "null". But that does not seem to be an issue for the first app :/

On 25 January 2017 at 15:56, Matthias Wessendorf <[hidden email]> wrote:
and the tool that intercepts the requests also sends back some meaning full reponse ? 

like described here:



On Wed, Jan 25, 2017 at 3:49 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:
Yes, the proxy is up and the -Dcustom.aerogear.fcm.push.host is set, the notifications are actually being sent.

On 25 January 2017 at 15:44, Matthias Wessendorf <[hidden email]> wrote:
endpoints for thje /fcm/send mock are setup ? 



On Wed, Jan 25, 2017 at 2:07 PM, Jose Miguel Gallas Olmedo <[hidden email]> wrote:

---------- Forwarded message ----------
From: Jose Miguel Gallas Olmedo <[hidden email]>
Date: 25 January 2017 at 13:00
Subject: Mysterious warning when sending push
To: AeroGear Developer Mailing List <[hidden email]>


Hi all,

I have some phenomenon here. I have created 4 variants with 100 fake tokens and sending 1 push through the mock FCM server. What I got is 400 (401 to be exact) receivers so it seems to work OK.

These are the 4 variants (the order is important):


However ONLY on 2nd to 4nd variant I got this warning:



The first variant in the list is not getting the error. I created them in order (0 - 3) so this does not matter because the 0 (second in the list) is receiving the warning but the 1 (first in the list) is not.

​Look what happens if I delete the first variant in the list and send another notification:

​(Now the first in the list is variant 0, the former 2nd in the list)



​This is no longer receiving the warning!​


So what do you think? Bug? It does not seem to be related with the fact that I am using the FCM proxy... or does it? Maybe I'm missing something obvious.

Cheers,

--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633



--
Project lead AeroGear.org



--
Jose Miguel Gallas Olmedo
Associate QE at Mobile Team, Red Hat
<a href="tel:+34%20618%2048%2086%2033" value="+34618488633" target="_blank">+34 618 488 633

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev



--

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev
Loading...