[aerogear-dev] AEROGEAR-559 android: can only build with -DskipTests

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[aerogear-dev] AEROGEAR-559 android: can only build with -DskipTests

Bruno Oliveira
Hi everybody! I was reviewing Marko's PR (https://github.com/aerogear/aerogear-android/pull/14), but as you know I'm not so good with Android, so here comes a few dumb questions.

Following the documentation http://developer.android.com/guide/topics/manifest/uses-sdk-element.html these attributes specifies what's the mininum API level required and the targetSdkVersion attribute specifies the API level that application targets, right? Are we targeting only the API level 7?

android:minSdkVersion="7"
android:targetSdkVersion="7"

Why targetSdkVersion can't be 16 for example? Just because RoboEletric uses the API level 10 as default?

Maybe is just a matter of configure RoboEletric plugin instead of change the targetSdkVersion?



-- 
"The measure of a man is what he does with power" - Plato
-
@abstractj
-
Volenti Nihil Difficile

_______________________________________________
aerogear-dev mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-dev